Go Back   Maxima Forums > Maxima Discussions > 4th Generation Maxima (1995-1999)
Sign in using an external account
Register Forgot Password?
Register Photos FAQ Timeslips Members Parts Guide Search Today's Posts Mark Forums Read ExperienceVendorsUsed CarsGarage TSB & Recalls
Search

4th Generation Maxima (1995-1999) Visit the 4th Generation forum to ask specific questions or find out more about the 4th Generation Maxima.

Welcome to Maxima.org!
Welcome to Maxima.org,

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to start new topics, reply to conversations, privately message other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join Maxima.org today!


Reply
 
 
 
 
Thread Tools Search this Thread Display Modes
Old 04-23-2002, 06:04 AM   #1
Junior Member
 
Join Date: Oct 2001
iTrader: (0)
Posts: 19
Knock Sensor Symptoms

Does anyone know what the symptoms are for a Knock Sensor being bad.
I drove my car for 20,000 miles with the mil light on and new I had a code 130 and 150. I did not notice any loss of power. I now have a loss of power and the car dies sometimes when I come to a stop. I just did a diagnostic check and I have Oxygen Sensor Right(130) and Left bank(150), Speed Sensor(500) and Knock sensor(325).
__________________
BattleBotsJudge
BattleBotsJudge is offline   Reply With Quote
Old 04-23-2002, 09:44 AM   #2
Senior Member
 
Join Date: Jul 2001
iTrader: (0)
Posts: 7,533
Send a message via ICQ to SuDZ Send a message via AIM to SuDZ
Bad knock sensors can give bad gas milage.Bad performance , as in less power. thigns to that effect.

SuDZ
__________________
'98 Se 5 Speed.
My Cardomain site for my Z
SuDZ is offline   Reply With Quote
Old 04-23-2002, 09:55 AM   #3
Senior Member
 
Join Date: Dec 2001
iTrader: (0)
Posts: 2,085
Most people on the org have suggested that the KS codes tends to come on as ride along to O2 sensor problems sometimes and if the problem of the O2's is corrected and it STILL comes on then it needs to be changed.

To me, it sounds like your car has other issues besides the KS. I would address the sensors first, reset the ECU, and if the KS comes back THEN change it. It is not a super cheap sensor and a real pain to reach, but can be done with a very long extension, swivel, and a 12mm socket.
__________________


With the Maxima that's in ICU:
TSC Member#6
13.335@108MPH- 08/23/02
OBMC Member#42
JAIMECBR900 is offline   Reply With Quote
Old 04-23-2002, 01:18 PM   #4
Junior Member
 
Join Date: Oct 2001
iTrader: (0)
Posts: 19
Re: Knock Sensor Symptoms

Quote:
Originally posted by BattleBotsJudge
Does anyone know what the symptoms are for a Knock Sensor being bad.
I drove my car for 20,000 miles with the mil light on and new I had a code 130 and 150. I did not notice any loss of power. I now have a loss of power and the car dies sometimes when I come to a stop. I just did a diagnostic check and I have Oxygen Sensor Right(130) and Left bank(150), Speed Sensor(500) and Knock sensor(325).
Thanks for the information. I am in the process of purchasing the sensor's on line and will forward my results.
__________________
BattleBotsJudge
BattleBotsJudge is offline   Reply With Quote
Old 04-23-2002, 01:26 PM   #5
Junior Member
 
Join Date: Oct 2001
iTrader: (0)
Posts: 19
Quote:
Originally posted by JAIMECBR900
Most people on the org have suggested that the KS codes tends to come on as ride along to O2 sensor problems sometimes and if the problem of the O2's is corrected and it STILL comes on then it needs to be changed.

To me, it sounds like your car has other issues besides the KS. I would address the sensors first, reset the ECU, and if the KS comes back THEN change it. It is not a super cheap sensor and a real pain to reach, but can be done with a very long extension, swivel, and a 12mm socket.
I measured the resistance of the Oxygen sensors and they were at 5.9 ohms. The shop manual say's it's supposed to be around 2.3 to 4.3 ohms, so I will order them today. I measured the resitance of knock sensor and it was out of specification? Although, I am not sure though that I found the right knock sensor connector. I will reverify the connector location tonight. Thanks for the post.
__________________
BattleBotsJudge
BattleBotsJudge is offline   Reply With Quote
Old 04-24-2002, 03:02 PM   #6
Junior Member
 
Join Date: Mar 2002
iTrader: (0)
Posts: 29
Quote:
Originally posted by BattleBotsJudge


I measured the resistance of the Oxygen sensors and they were at 5.9 ohms. The shop manual say's it's supposed to be around 2.3 to 4.3 ohms, so I will order them today. I measured the resitance of knock sensor and it was out of specification? Although, I am not sure though that I found the right knock sensor connector. I will reverify the connector location tonight. Thanks for the post.

hey I have a 95 gxe and it kept stalling with out any notice as well, took it to the dealer and they said it waqs either the knock sensor, coolant valve sensor or the purge volume control connector = $850.00 to repair all 3. I was not going for it! I had the first 2 problems fixed and really didn't need the third fixed and paid less to get it done. get the coolanr valve senor fixed first ($48.00 part)and see if you have the same problem, if still acting up, then get the knock sensor fixed ($125.00 part). hope this helps just passing on the knowledge.
bbrown is offline   Reply With Quote
Old 06-09-2002, 09:14 PM   #7
Junior Member
 
Join Date: Oct 2001
iTrader: (0)
Posts: 19
Quote:
Originally posted by bbrown



hey I have a 95 gxe and it kept stalling with out any notice as well, took it to the dealer and they said it waqs either the knock sensor, coolant valve sensor or the purge volume control connector = $850.00 to repair all 3. I was not going for it! I had the first 2 problems fixed and really didn't need the third fixed and paid less to get it done. get the coolanr valve senor fixed first ($48.00 part)and see if you have the same problem, if still acting up, then get the knock sensor fixed ($125.00 part). hope this helps just passing on the knowledge.
bbrown,

Thanks for the information. I bought a knock sensor but did not replace it because when I checked the resistance it was okay. I will order the coolant valve sensor first.

Sorry for not responding sooner, BattleBots Judge.
__________________
BattleBotsJudge
BattleBotsJudge is offline   Reply With Quote
Old 06-10-2002, 07:24 AM   #8
Junior Member
 
Join Date: Mar 2002
iTrader: (0)
Posts: 29
coolant valve sensor

Quote:
Originally posted by BattleBotsJudge


bbrown,

Thanks for the information. I bought a knock sensor but did not replace it because when I checked the resistance it was okay. I will order the coolant valve sensor first.

Sorry for not responding sooner, BattleBots Judge.

Hey, no problem, after I got the coolant valve sensor, no more engine cutting off.

good luck
bbrown is offline   Reply With Quote
Old 06-10-2002, 09:26 AM   #9
Newbie - Just Registered
 
Join Date: Jun 2002
iTrader: (0)
Posts: 1
I have a '95 GXE w/ ~90K miles. The knock sensor was replaced at ~40K miles and I fear it it is going bad again. The MIL has not come on and it did not come on when it malfunctioned previously. My symptom is a noticable loss of power at low RPM's, almost like a stutter or miss, and bad gas mileage. I've read that these are not too difficult to replace. Can anyone send me information on where it is located and how to replace it? Also, where's the best place to get parts these days? A have always dealt with Courtesy Nissan in the past.
Mattw is offline   Reply With Quote
Old 06-10-2002, 09:50 AM   #10
Senior Member
 
Join Date: Aug 2000
iTrader: (0)
Posts: 2,530
Send a message via AIM to ericdwong
Quote:
Originally posted by JAIMECBR900
Most people on the org have suggested that the KS codes tends to come on as ride along to O2 sensor problems sometimes and if the problem of the O2's is corrected and it STILL comes on then it needs to be changed.

To me, it sounds like your car has other issues besides the KS. I would address the sensors first, reset the ECU, and if the KS comes back THEN change it. It is not a super cheap sensor and a real pain to reach, but can be done with a very long extension, swivel, and a 12mm socket.
Hmmm this is curious. On my way back from the NE meet yesterday, my CEL came on. Today I pulled the code and it was the 0304 which is the front O2 sensor. Its possible I did not put it in right or I busted a wire after doing NUMEROUS Y pipe /OEM pipe install/deinstalls.

Since I should be getting my damn Y pipe back soon I will swap the front and back O2 sensors and see if it changes anything.

I then tried the resistance check on my Knock Sensor. I had my ohmmeter set to RX 1K range and the meter read in the neighborhood of 500K x1000x, so this would mean my KS resistance is at 500,000 ohms. Either my ohmmeter is smoking crack, or my KS is shot. 0304 (the KS code) didnt come up though. I wonder whats up.
ericdwong is offline   Reply With Quote
Old 06-10-2002, 09:59 AM   #11
Supporting Maxima.org Member
 
Join Date: Apr 2002
Location: Shreveport, LA
iTrader: (3)
Posts: 272

Quote:
Originally posted by Mattw
I have a '95 GXE w/ ~90K miles. The knock sensor was replaced at ~40K miles and I fear it it is going bad again. The MIL has not come on and it did not come on when it malfunctioned previously. My symptom is a noticable loss of power at low RPM's, almost like a stutter or miss, and bad gas mileage. I've read that these are not too difficult to replace. Can anyone send me information on where it is located and how to replace it? Also, where's the best place to get parts these days? A have always dealt with Courtesy Nissan in the past.
Go here:

http://www.skippynet.com/maxima/knocksensor.htm
__________________
PhatBastard is offline   Reply With Quote
Old 06-10-2002, 11:06 AM   #12
Senior Member
 
Join Date: Apr 2002
iTrader: (2)
Posts: 2,958
Send a message via AIM to Jamsan
Quote:
Today I pulled the code and it was the 0304 which is the front O2 sensor
Quote:
0304 (the KS code) didnt come up though. I wonder whats up.
whoops?
__________________
1997 Maxima Neptune Blue SE
In Regards to Nissan Service Department:
<xxxxx>Why do i bend over and constantaly take it in the *** from nissan
<xxxxx> need to replace my coil packs there gonna ask me do you want that with or without lube
Jamsan is offline   Reply With Quote
Old 06-10-2002, 11:06 AM
MaximaOrg
Nissan Maxima




Paid Advertisement
 
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off


 




All times are GMT -7. The time now is 12:00 PM.


Maxima.org Forums Home Here you can view your subscribed threads, work with private messages and edit your profile and preferences Frequently Asked Questions on the Forums Search Find other members Registration is free! Support Maxima.org! Receive perks and benefits by donating to Maxima.org Questions? Comments?  Suggestions? Contact Us! Visit our Sponsors View and submit Maxima events Log Out of Maxima.org
Emails Backup

Search Engine Optimization by vBSEO 3.5.2